WampServer with PHP 5.4.3 fails to load Curl extension [Solved]

After starting the WampServer on x64 with PHP 5.4.3, you see the following error:

PHP Startup: Unable to load dynamic library ‘…/php_curl.dll’ – The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail

The php_curl.dll library is bugged and must be replaced. See attachment below. Replace the old php_curl.dll file (in your wampserver/bin/php/{version}/ext/ folder) with the new one attached. Restart Apache and you are set.

Solution found at http://forum.wampserver.com/read.php?2,85716

php_curl-5.4.3-VC9-x64

Leave a comment